Join Our Ford Truck Forum Today

Document your Ford truck project here and inspire others!

Genset engine

DNFXDLI

The Token Canadian
Staff member
Wasn't sure where to post this, figured here might be best. The engine on my RV genny is a 4 cyl Yanmar, 4tn82 series...IDI with a mechanical injection pump and return line.

Does not have a mechanical fuel pump and is set run with a governor and fuel shutoff solenoid just like a welder.

It has an electric pump which you can activate for priming when the genny is not running....once the genny is running a relay drops out and the prime does not work.

So here is the situation...

Genny has on occasion run for 10-20 min and then starts to sputter and drop rpm...does it under load or no load. Finally went through it yesterday and to my surprise a diode was open that feeds the power to the fuel pump.

In effect, there was no lift pump at all....so is/was it possible that the injection pump was able to keep it running (for the most part)?
 

heavydoc

Instigator
Staff member
1,969
38
WNC
Wasn't sure where to post this, figured here might be best. The engine on my RV genny is a 4 cyl Yanmar, 4tn82 series...IDI with a mechanical injection pump and return line.

Does not have a mechanical fuel pump and is set run with a governor and fuel shutoff solenoid just like a welder.

It has an electric pump which you can activate for priming when the genny is not running....once the genny is running a relay drops out and the prime does not work.

So here is the situation...

Genny has on occasion run for 10-20 min and then starts to sputter and drop rpm...does it under load or no load. Finally went through it yesterday and to my surprise a diode was open that feeds the power to the fuel pump.

In effect, there was no lift pump at all....so is/was it possible that the injection pump was able to keep it running (for the most part)?
Yes, I have seen some that would run without the lift pump, although it was a bear to start. I have seen them a bear to start and then run poorly. The lift pump(electric) should be running all the time. It only gives you about 1.5 to maybe 3.5 psi. Should I get the Mpa or bar spec for ya? 🤣
 

dustybumpers

don't play well w others
I re-wired my lift pump on mine to run constant. Just make sure to keep the pressure below 5 lbs.
No faith in a mechanical pump anymore
 

DNFXDLI

The Token Canadian
Staff member
Thanks guys. Ordered a diode and I will update once I get it installed.
 
Top